How can I install/upgrade Modals?

You can either install Modals by using the core extension manager available in the Joomla! Administrator Control Panel, or by using the powerful Regular Labs Extension Manager.

Note: When updating Modals, you do not need to uninstall it first. The package will update all the files automatically.

Keep in mind that when you update to a major new version (or uninstall first), you might lose some configuration settings.

Modals won't install...

If you have problems installing Modals, please try the manual installation process as described here: docs.joomla.org/Installing_an_extension

How can I uninstall Modals?

You can either uninstall Modals by using the core extension manager available in the Joomla! Administrator Control Panel, or by using the powerful Regular Labs Extension Manager.

If you no longer use any Regular Labs extensions, you can also uninstall the Regular Labs Library plugin by using the Joomla! core extension manager.

What are the minimum requirements?

Modals will only work correctly if your setup meets these requirements:

  • Up-to-date version of Joomla:
    • Joomla 3.9.0 or higher
  • PHP 7.2 or higher
  • MySQL 5 or higher

Important: I can only provide support for setups that:

  • meet the above requirements;
  • do not have extension files or Joomla! core files that have been altered in any way.

Where can I download earlier versions?

You have access to all previous free versions of all extensions on this website.

If you have a subscription to an extension, you can also download any previous pro version of that extension.

If you do not have a valid subscription, you can download any pro version that is older than 1 year.

You can find old versions on the Download page.

Note: Please note that I am unable to provide support on old versions! (whether you have a subscription or not).

How to Upgrade Modals from Joomla 3 to Joomla 4

Modals is not yet compatible with Joomla 4.

Refer to our Joomla 4 Plans and Roadmap for an indication of when it will be made available for Joomla 4.

If your site depends on Modals, we recommend you wait before upgrading your site to Joomla 4.

How can I downgrade to an earlier version of Modals?

If for some reason you need to install an older version, it is best to uninstall the extension first.

You will also have to uninstall the Regular Labs Library system plugin.

After that, you can simply install the older version zip file using the Joomla! installer.

Note: Please note that I am unable to provide support on old versions!